System Requirements

In order to access and use the system, you can use any modern web browser, such as Google Chrome, Firefox (FF3 or newer recommended), Internet Explorer (IE8 or newer recommended), Opera or Safari. We do not support earlier web-browsers, such as Internet Explorer 6 or Internet Explorer 7.

 

Browser Logos

 

We also recommend the following:

  • Adobe Reader is required in order to be able to view printed PDF documents, such as invoices. Adobe Reader can be downloaded for free from http://get.adobe.com/reader/
  • Spreadsheet programme such as Microsoft Excel or OpenOffice Calc
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk